Re: Simple XML Event-Based API for Java

Don Park (donpark@quake.net)
Tue, 16 Dec 1997 20:44:22 -0800


David,

Looks good in general. I have only a few comments and a couple of
questions.

<comment type="renaming familiar pattern">
I would rename XmlApplication and XmlProcessor to XmlConsumer and
XmlProducer. It is just matter of current Java API tradition.
Additionally, I would write a helper class XmlFilter.
Producer/Filter/Consumer arrangement is a well known design pattern and it
would be confusing to rename it.
</comment>

<comment type="terminology">
I would rename startProlog, endProlog, and processingInstruction to
something more friendly. To most beginner XML programmers, they wouldn't
know what PI is nor would they care. I would group all "abnormal" tags
(with the exception of comments) as special elements and have a separate
pair of start/end for them. I would add a separate method for comments
text. Renaming characters() to content() might make it more clear to
programmers about what the method does.
</comment>

<comment type="silly">
I would also rename xetPublicId and xetSystemId to xetPublicID and
xetSystemID. I usually change acronyms when they are used as prefix (XML to
Xml) but not when they are used to postfix a name. It tend to look more
legible.
</comment>

<question>
Would entities be resolved by XmlProcessor er, XmlProducers?
</question>

Don